[SJ8 Pro] Won't turn on

Discussion in 'SJ8 Series' started by czesio666, Oct 8, 2020.

  1. czesio666

    czesio666 New Member

    Joined:
    Dec 23, 2019
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    poland
    Earlier I noticed problem with usb connection (see previous posts) but today the camera died.
    When I turn the camera on, it makes a sound, the blue led is on but the screen is not turning on. Then the camera hangs and one has to remove the battery to turn it off. The same happens when it is connected to power supply with or without the battery. With battery the red light is on.

    I have observed the same reaction two days ago. But after several attempts the camera started working normally. Today it won't.

    Any ideas what could be wrong?

    I cannot run it in bootloader mode as the camera is not detected in pc (https://sjcam.com/community/threads/sj8-pro-usb-connection-stopped-working.18275/).
     
  2. czesio666

    czesio666 New Member

    Joined:
    Dec 23, 2019
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Location:
    poland
    Just to inform. The problem was in memory card. There was something wrong with its connection. Dirty connectors or something like this. Memory card is working ok. I have cleaned connector and till today everything is working ok.
    I didn't expect that problems with memory card access could freeze the camera during power up.
     

Share This Page