SJ Legend 6 not starting up...

Discussion in 'SJ6 LEGEND' started by Simon Goh, Oct 30, 2017.

  1. Simon Goh

    Simon Goh New Member

    Joined:
    Oct 28, 2017
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Gender:
    Male
    As above, tried with the latest firmware and bin files, but all i got are the 2 lights in front and nothing appears on the screen. please help!!
     
  2. Sulev Svilponis

    Sulev Svilponis Elite

    Joined:
    Aug 11, 2017
    Messages:
    548
    Likes Received:
    117
    Trophy Points:
    43
    Gender:
    Male
    Maybe it would help if you just eject the memory card from the camera?
    Could you describe, what did you do, step by step, and what happened? Was there anything abnormal before you reached to the present situation?
     
  3. Simon Goh

    Simon Goh New Member

    Joined:
    Oct 28, 2017
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Gender:
    Male
    Hi Sulev, thanks for your reply.

    I didn't try restarting without memory card. I'll try later this evening.

    I was trying to update firmware, so I copied the new firmware bin file into memory card and restart. Only the lights in front turned on without the screen. Then I change the SJAM bin file to 001.bin, restart the cam but still the same. Then I copied the installer bin file into the memory card and restart also without any success.
     
  4. Sulev Svilponis

    Sulev Svilponis Elite

    Joined:
    Aug 11, 2017
    Messages:
    548
    Likes Received:
    117
    Trophy Points:
    43
    Gender:
    Male
    From where did you get these instructions? Did you try to hack your camera (install your own customised firmware)?
    Follow these instructions:
    http://support.sjcam.com/support/solutions/articles/9000101553-sj6-legend-latest-firmware
    Always format the card or delete bin files from it after any firmware update! Otherwise the camera tries to update its firmware, each time you power the camera on. For normal operation, there should be no bin files on the root folder of the card.

    I downloaded the loader, recommended by the link above. Opened it in a hex editor and found, that the loader expects, that the firmware file (SJ6CAM.bin) should be renamed to SJCAM001.bin, before you try to update the firmware.

    So try this:
    1. format your memory card in the computer.
    2. download the LD96660A.bin and put it on the card.
    3. insert the card into the camera and push the power button for ca 5 sec.
    4. wait until the loader is installed (3 minutes should be more than enough)
    5. turn the camera off, if it is on (lights on).
    6. delete loader file from the memory card
    7. download the firmware file, rename it to SJCAM001.bin and put it to the card
    8. insert the card into the camera and push the power button for ca 5 sec.
    9. wait until the firmware is installed (3 minutes should be more than enough)
    10. format the card in camera, if the camera has powered up, or power the camera down, remove the card and delete the FW file from it.
     
    Last edited: Oct 31, 2017
  5. Simon Goh

    Simon Goh New Member

    Joined:
    Oct 28, 2017
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Gender:
    Male
    Thanks Sulev for your clear instructions.

    To answer your questions.
    1. I got the instructions from the same link as you have attached.
    2. No i didnt hack the cam using customized upgrades

    Anyway I have followed your instructions with much hope. I got the red, blue and white light when installing the loader file. And just the red and blue light when installing the firmware. The camera failed to power up after 3-5 minutes wait. :(
     
  6. Sulev Svilponis

    Sulev Svilponis Elite

    Joined:
    Aug 11, 2017
    Messages:
    548
    Likes Received:
    117
    Trophy Points:
    43
    Gender:
    Male
    Try again! If possible, try another memory card. Do not omit formatting step! Even if the card is brand new and should be preformatted in the factory, format it with a computer. If your computer runs on Linux, then try to find a Windows computer for formatting, because some Linuxes use slightly different formatting, that can cause problems.
    Skip the loader part (steps 2...6)!
    Use this FW (1.4.6): http://support.sjcam.com/helpdesk/attachments/9029811676
    Decompress the file first.

    You may also try to rename the FW file to FW96660T.BIN
    Hope that this helps!
     
    Last edited: Oct 31, 2017
  7. Simon Goh

    Simon Goh New Member

    Joined:
    Oct 28, 2017
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Gender:
    Male
    Oh my god :)
    This time it works and my cam starts up like a charm.
    Thank you Sulev so so much for your patience and help :))
    This is just in time for my Dec trip. Can't thank you enough for this!!!!!!
    Cheers and have a good day!
     
  8. Sulev Svilponis

    Sulev Svilponis Elite

    Joined:
    Aug 11, 2017
    Messages:
    548
    Likes Received:
    117
    Trophy Points:
    43
    Gender:
    Male
    You are welcome! :)
    But for other camera owners with similar problem, could you specify, did you rename the FW file to FW96660T.BIN or not?
     
  9. Simon Goh

    Simon Goh New Member

    Joined:
    Oct 28, 2017
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Gender:
    Male
    Yes I did. Also realized the file size of your sjcam bin file is different from that in the official link, if that matters.
     
  10. Sulev Svilponis

    Sulev Svilponis Elite

    Joined:
    Aug 11, 2017
    Messages:
    548
    Likes Received:
    117
    Trophy Points:
    43
    Gender:
    Male
    The latest FW link, that I gave, was to the previous version of the FW (1.4.6). The first link was to the latest FW (1.4.7). You may try to update your camera to the latest FW also, by renaming this FW file to FW96660T.BIN.
    It is sad, that SJCAM does not remember, what file name is expected for the FW file by their new loader, and are sharing false instructions about that. I found it out by opening the loader file in the hex editor and researching it.
     
    Simon Goh likes this.
  11. Simon Goh

    Simon Goh New Member

    Joined:
    Oct 28, 2017
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Gender:
    Male
    After my cam died on me a few months ago, I'm very happy with what i have already, if theres no significant upgrade to 1.4.7.
     
  12. Sulev Svilponis

    Sulev Svilponis Elite

    Joined:
    Aug 11, 2017
    Messages:
    548
    Likes Received:
    117
    Trophy Points:
    43
    Gender:
    Male
    Actually the latest is ver 1.4.8 (the link has confusing end 1-4-7. Also, according to the change log it seems, that they released again at least two different versions of the v1.4.8 - the August 30th version and the September 4th version. Will they ever learn?)
    http://support.sjcam.com/support/solutions/articles/9000130766-sj6-legend-firmware-ver-1-4-7/

    SJ6 v1.4.8 Changelog:
    20170830
    1. Optimizes Russian translation
    2. solve the connection in the HDMI, the next row of a regular UI will flash the problem
    3. Resolves After opening wifi, and connecting to camera, the icons dissapear and there is an issue recording with app issue.
    5. When the fish eye correction function is turned on, there is gray FOV menu (FOV turned off)
    6. Since the white balance menu and the color menu in the menu have overlap, one of the two’s menus is grayed out when the other one is turned on.
    7. Updated English Menu: Delay Capture -> Selfie Timer
    8. Resolved slow video settings not saving issue.
    9. Resolved the smaller font in the menus after screen was scrolled.
    Sept 4 Updates:
    10. Resolves when selecting delete in video playback, the video continues to play, and cannot delete file.
    11. Fixes issue in burst mode when first image has quality issues.
    12. -2X Slow Motion now uses 1080p.

    ********************************************************************************************

    SJ6 V1.4.7 Changelog:
    1. Resolves issue that occurs when HDMI is connected and touch screen cannot operate and goes into playback mode.
    2. Resolves issue when connected to HDMI and power unit off, the LOGO display anti-90 degrees
    3. Adds a user guide (Wizard) which appears first time after restoring factory settings or upgrading to new firmware. Guide will display basic operations.
    4. Added function: after restoring factory settings, a guide will appear when going into normal video mode.
    5. Fixes when in FPV mode and connect HDMI, the unit freezes due to HDMI AV-out not being able to operate at the same time. Now only one video stream output can be selected at time.
    6. Adds ISO 3200 manual control
    7. to solve the closure of the cycle of video, the video to the card after the card full of tips have not disappeared, can not operate the TP problem
    8. Optimize the function can not be effective at the same time, the menu to increase the gray background, such as open the gyroscope, FOV and fish eye correction menu becomes gray, then click on the button can not enter the secondary menu or button OK button can not enter the secondary menu
    9. In the menu under the two menu, press the power button down options, this time if the slide TP, press the power button down, there will be a disorder problem
    10. Set the camera to set the camera mode, the photo set to 12M, and then shut down; and then boot, and then open the wifi, mobile phone camera wifi, camera crash
    11. Under the Optimize menu, click into the secondary menu and the response speed returned after the second menu selection
    12. Optimize left and right sliding switch mode speed and camera busy tips too frequently to solve the problem, after optimization, sliding switching mode should be faster than before 2 to 3 times
    13. solve the problem: in the camera mode, select the watermark off, take pictures out of the picture will still have watermark information
     
  13. Simon Goh

    Simon Goh New Member

    Joined:
    Oct 28, 2017
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    3
    Gender:
    Male
    I've updated FW to 1.4.8 and it works after i rename it to FW96660T.bin
     
    Sulev Svilponis likes this.
  14. Sulev Svilponis

    Sulev Svilponis Elite

    Joined:
    Aug 11, 2017
    Messages:
    548
    Likes Received:
    117
    Trophy Points:
    43
    Gender:
    Male
    Thanks for sharing! That should be helpful for the other SJ6 owners!
     
  15. Clyde

    Clyde New Member

    Joined:
    Mar 16, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Hello!
    Got brand new S6 legend yesterday. I plugged it into my pc and turned it on and only changed language, date and time. I left it charging for an hour and when i got back camera had crashed(blue screen and buttons not responsive). Now when i try to turn it on,only red and blue led lights in front of the camera will light up and nothing else happens,screen stays black.When i hold the power button again led lights will go out.
    I tried all these firmware and loader file fixes exactly as described above and did not forget to format sd card. And still same problem..
    Can someone please help?
     
  16. Sulev Svilponis

    Sulev Svilponis Elite

    Joined:
    Aug 11, 2017
    Messages:
    548
    Likes Received:
    117
    Trophy Points:
    43
    Gender:
    Male
    Did you try, if the camere can still record? Maybe the problem is related with the screen ony?
    You should probably ask for warranty repair/replacement.
     
  17. Clyde

    Clyde New Member

    Joined:
    Mar 16, 2018
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Yes i tried, it does not record. Only red and blue led lights at the front of the camera will light up,nothing else happens
    Seems to me that i have to send it back
     
  18. JULR1976 .

    JULR1976 . New Member

    Joined:
    Aug 20, 2019
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Hello all...
    I just buyed my SJ6 legend...did some short videos and battery ends... i tried to recharge...then as said before i had just 2 lights reds on...search for the answer i found this forum...did all steps to dowload the last firmware 1.5.1 what i got?? the cam works bizarre , like the colors are inverse and touchscreen doesnt work anymore... sj6a.jpg sj6b.jpg
     
  19. Sulev Svilponis

    Sulev Svilponis Elite

    Joined:
    Aug 11, 2017
    Messages:
    548
    Likes Received:
    117
    Trophy Points:
    43
    Gender:
    Male
    Maybe you upgraded to the incompatible FW?
    Try to downgrade to the original one.
     
  20. RJcam

    RJcam New Member

    Joined:
    Apr 29, 2019
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    I have the same problem as JULR1976. Touch screen no longer responsive after trying to reinstall v1.5.1 update from the factory site. I had V1.5.1 dated 12-14-2018 before trying to reinstall. Is there a place to download a newer copy of the v1.5.1 firmware beside the SJCAM.com site? My SJ6 Legend is newer version without HDMI port. Also same problem after trying to install v1.4.9 firmware, screen icons are black and touchscreen unresponsive.
     

Share This Page