Power issue?

Discussion in 'SJ8 Series' started by mi6t0, Jun 10, 2018.

  1. mi6t0

    mi6t0 New Member

    Joined:
    Jun 21, 2017
    Messages:
    7
    Likes Received:
    2
    Trophy Points:
    3
    Gender:
    Male
    Location:
    Sofia
    I have the SJ8 pro and there seems to be an issue with the power on options:

    If I power on the camera and do NO recordings, then ppwer it off , then do it once again - the camera will not power on any more.
    The only way to fix this is to remove the battery for a minute.

    Anyone else facing this issue?
     
  2. Sulev Svilponis

    Sulev Svilponis Elite

    Joined:
    Aug 11, 2017
    Messages:
    529
    Likes Received:
    113
    Trophy Points:
    43
    Gender:
    Male
    What mode do you use? Is this issue mode dependant or not?
     
  3. mi6t0

    mi6t0 New Member

    Joined:
    Jun 21, 2017
    Messages:
    7
    Likes Received:
    2
    Trophy Points:
    3
    Gender:
    Male
    Location:
    Sofia
    I used mostly video mode, but it is not mode dependant. Any kind of it could cause it.
    I already tried factory reset. The issue occurs bith on 1.10 and 1.20.
    Resolutions don't matter, neither do fps. Also Gyro on/off makes no difference. It seems to be either firmware bug, or battery problem, or perhaps board/pcb.
     
    Eric5150 likes this.
  4. 88 Photography

    88 Photography New Member

    Joined:
    Dec 5, 2017
    Messages:
    7
    Likes Received:
    2
    Trophy Points:
    3
    Gender:
    Male
    I am having the same issue- have to remove the battery to be able to power on again
     
  5. 88 Photography

    88 Photography New Member

    Joined:
    Dec 5, 2017
    Messages:
    7
    Likes Received:
    2
    Trophy Points:
    3
    Gender:
    Male
    Now the audio is noise and crackling sound- what else could go wrong-yikes- i ordered it from china off ebay it was legit i checked the authentic scratch off code on the box and was good- wonder what are my chances of getting it replaced?
     
  6. Andre

    Andre New Member

    Joined:
    Jul 1, 2017
    Messages:
    25
    Likes Received:
    14
    Trophy Points:
    3
    Gender:
    Male
    Occupation:
    Filmmaker & tester of gadgets
    Location:
    Texas U.S.A.
    Not a single issue with mine
    <----Knocks on wood
     
  7. SJCAM_Support

    SJCAM_Support Moderator Staff Member

    Joined:
    Mar 6, 2017
    Messages:
    219
    Likes Received:
    202
    Trophy Points:
    43
    Gender:
    Male
    We have reported the problem to our engineering department.

    We are not sure it is battery defect or software glitch but we will try our best to solve the problem asap.
     
    Damian Holt likes this.
  8. 88 Photography

    88 Photography New Member

    Joined:
    Dec 5, 2017
    Messages:
    7
    Likes Received:
    2
    Trophy Points:
    3
    Gender:
    Male
    I downloaded the latest firmware version 1.2.1 and i still have the same issue- have to pull the battery out put back and it sometimes powers back on- hopefully you can fix this issue soon
     
  9. mi6t0

    mi6t0 New Member

    Joined:
    Jun 21, 2017
    Messages:
    7
    Likes Received:
    2
    Trophy Points:
    3
    Gender:
    Male
    Location:
    Sofia
    Where did you get the firmware from? I saw it mentioned on youtube, but no link here :\
     
  10. 88 Photography

    88 Photography New Member

    Joined:
    Dec 5, 2017
    Messages:
    7
    Likes Received:
    2
    Trophy Points:
    3
    Gender:
    Male
    Through the app
     
  11. 88 Photography

    88 Photography New Member

    Joined:
    Dec 5, 2017
    Messages:
    7
    Likes Received:
    2
    Trophy Points:
    3
    Gender:
    Male
  12. mi6t0

    mi6t0 New Member

    Joined:
    Jun 21, 2017
    Messages:
    7
    Likes Received:
    2
    Trophy Points:
    3
    Gender:
    Male
    Location:
    Sofia
    Confirming that firmwares 1.2.3 and 1.2.4 no longer have the power issue symptoms. Well done SJCAM! :)
     
    Damian Holt likes this.
  13. Andrew Cz.

    Andrew Cz. New Member

    Joined:
    Apr 10, 2019
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    1
    Gender:
    Male
    Hello!
    I had the same problem, and I had to upgrade the firmware using an USB cable.
    Here are the instructions: support.sjcam.com/support/solutions/articles/9000151251-sj8-pro-usb-upgrade
    After doing this the problem was gone, and now the camera works perfectly!

    Best regards,
    Andras.
     

Share This Page