New camera crashes 1s after turning on

Discussion in 'SJ7 Star' started by feliks86, Nov 28, 2018.

  1. feliks86

    feliks86 New Member

    Joined:
    Oct 13, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    I just bought new camera SJ7 Star. I made a few minutes of recordings and then very problem appeared. After turning camera on, for 1 second on screen is displayed picture from lens and then screen goes blank, there is no picture on the screen, only backlight of screen is visible. If that happens, there is no way to turn camera off by power button - I need to remove battery. When camera is crashed like that, pushing buttons results in standard button sound, but nothing happens. After reinserting battery and powering camera again, this problem appears again. And that happens dozen times. One of dozen attempts to power on camera is successful, rest ends with blank screen and crash. I read that camera crashes often are caused by not supported SD cards, but SD card in my camera is Kingston microSDXC Class 10 64GB - this memory card I bought from official polish SJCAM distributor, so it must be supported. What can cause this problem? I need to send camera to distributor for warranty repair? I am attaching a photo when camera is freezed. Please help.

    DSC_4226.JPG
     
  2. Sulev Svilponis

    Sulev Svilponis Elite

    Joined:
    Aug 11, 2017
    Messages:
    529
    Likes Received:
    113
    Trophy Points:
    43
    Gender:
    Male
    You may try to remove the memory card to verify, if that card is the culprit. No seller can guarantee, that all memory cards they sold, work flawlessly forever.
     
  3. feliks86

    feliks86 New Member

    Joined:
    Oct 13, 2018
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    It is not memory card fault. Problem appears also when I am turning camera on without any card. Also I tried a few different cards from 1GB to 64GB, different brands, and problem always appear. Today when camera once turned on correctly, I performed firmware upgrade from 1.21 to 1.22 and it not helped - problem still appears. Looks like it is camera fault :(
     
  4. Caio cesar eraclito de morais

    Caio cesar eraclito de morais New Member

    Joined:
    Aug 2, 2018
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    I have the same problem for a long time and Sjcam don't do anything to fix it, and unfortunately I can't return the Cam anymore to the Seller... it's very frustating, I never will buy another Sjcam anymore and I try to advertising anyone who want buy an Sjcam.
     
  5. Troy

    Troy Administrator Staff Member

    Joined:
    Feb 28, 2017
    Messages:
    10,247
    Likes Received:
    10,081
    Trophy Points:
    1,000
    Best to update firmware first, using a different card, Class 10 and above that is tested for speed.
    Unfortunately, there are plenty of cards out there that have fakespeed on the label, and this is sadly very common.
    Of course, if nothing that you have tried has worked on the first few days when your camera has arrived, fastest solution is to contact your seller.
     
  6. BAGOPRO

    BAGOPRO New Member

    Joined:
    Jan 30, 2019
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hi ,
    I have the same problem with this current camera and have had followed the same procedure as Feliks86.Initially bought two cameras from Amazon Australia fulfilled by Amazon and verified genuine by e-mail.Older versions with HDMI port 1 x black (newer W/proof housing )1 x silver(older w/proof housing) genuine SD cards from store in Australia.Had problems with the black camera and returned to Amazon for refund. Bought new SJ7 camera from same Amazon supplier,thought I would give it another chance, but nothing but problems.This is the latest version camera with no HDMI port.First off touch screen jumping around by itself from setting to setting.then Feliks86 exact same problem blank screen. Not the card,not firmware updates just a second faulty camera, as I have a fully functioning older silver model which has been updated to Version1.21. You tube will verify same problems. Bought two same model camera's to interchange,mounts. batteries ,use same app etc but I think will send both back before the silver one dies, buying and replacing 3 cameras is getting beyond a joke.My surfer mate has bashed and crashed his GOPRO Hero5 price vs reliability comes into question.
     

Share This Page